其他分享
首页 > 其他分享> > 【题解】【PAT甲】1148 Werewolf - Simple Version (20 分)

【题解】【PAT甲】1148 Werewolf - Simple Version (20 分)

作者:互联网

题目链接

 PTA | 程序设计类实验辅助教学平台

题目描述

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

结尾无空行

Sample Output 1:

1 4

结尾无空行

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

结尾无空行

Sample Output 2 (the solution is not unique):

1 5

结尾无空行

Sample Input 3:

5
-2
-3
-4
-5
-1

结尾无空行

Sample Output 3:

No Solution

结尾无空行

题目大意

 一共有N个人,两个狼人,有一个狼人和一个好人说谎,根据每个人说的找出真正的狼人

解题思路

 emm,当时做乙级题目就不会,现在继续参考柳婼

PAT 1148 Werewolf – Simple Version – 甲级_柳婼 の blog-CSDN博客

直接看代码解释吧

题解

#include<bits/stdc++.h>
using namespace std;
int main(){
	int n;
	cin>>n;
	vector<int> v(n+1);
	for(int i=1;i<=n;i++)	cin>>v[i];
	for(int i=1;i<=n;i++){
		for(int j=i+1;j<=n;j++){
			vector<int> lie,a(n+1,1);    
			a[i]=a[j]=-1;    //将好人初始化为1,狼人初始化为-1
			for(int k=1;k<=n;k++){
				if(v[k]*a[abs(v[k])]<0)    
                    //这个人说的那个人的身份和他实际的身份不符合,说明说谎了	
                    lie.push_back(k);
			}
			if(lie.size()==2&&            //有两个人说谎
            a[lie[0]]+a[lie[1]]==0){        //说谎的一个是狼人,一个是好人
				cout<<i<<" "<<j;
				return 0;
			}
		}
	}
	cout<<"No Solution"<<endl;
}

 

标签:空行,Sample,PAT,Werewolf,题解,there,player,werewolves,were
来源: https://blog.csdn.net/Elephant_King/article/details/121791115