其他分享
首页 > 其他分享> > 每日一淦2021.8.24

每日一淦2021.8.24

作者:互联网

ALDS1_1_D 在时间线上的最大利润。

Maximum Profit

You can obtain profits from foreign exchange margin transactions. For example, if you buy 1000 dollar at a rate of 100 yen per dollar, and sell them at a rate of 108 yen per dollar, you can obtain (108 - 100) × 1000 = 8000 yen.

Write a program which reads values of a currency $R_t$ at a certain time $t$ ($t = 0, 1, 2, ... n-1$), and reports the maximum value of $R_j - R_i$ where $j > i$ .

Input

The first line contains an integer $n$. In the following $n$ lines, $R_t$ ($t = 0, 1, 2, ... n-1$) are given in order.

Output

Print the maximum value in a line.

Constraints

Sample Input 1

6
5
3
1
3
4
3

Sample Output 1

3

Sample Input 2

3
4
3
2

Sample Output 2

-1

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main() {
int n,a[200000];
cin >> n;
for (int i = 0;i < n; i++)
cin >> a[i];
int min1 = a[0];
int max1 = -1000000000;
for (int i = 1; i < n; i++) {
max1 = max(max1, a[i] - min1);                 //max()和min()函数需要头文件带<algorithm>才能使用。
min1 = min(min1, a[i]);
}
cout << max1 << endl;
return 0;
}

标签:24,一淦,yen,int,2021.8,dollar,Sample,leq,min1
来源: https://www.cnblogs.com/NightVoyager233/p/15182836.html