其他分享
首页 > 其他分享> > PAT A1025. Ranking

PAT A1025. Ranking

作者:互联网


题目描述(原题即为英文题)
Programming Ability Test(PAT) is organized by the College of Computer Science and
Technology of Zhejiang University.Each test is supposed to run simultaneously in several places,
and the ranklists will be merged immediately after the test.Now it is your job to write a program to
correctly merge all the ranklists and generate the final rank.

输入格式
Each input file contains one test case.For each case,the first line contains a positive number N
(≤ 100),the number of test locations. Then N ranklists follow,each starts with a line containing a
positive integer K ( ≤300),the number of testees,and then K lines containing the registration
number (a 13-digit number) and the total score of each testee.All the numbers in a line are
separated by a space.

输出格式
    For each test case,first print in one line the total number of testees. Then print the final ranklist
in the following format:
   registration_number final_ rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of
   the final ranks.The testees with the same score must have the sa me rank,and the output must be
sorted in nondecreasing order of their registration numbers.

输入样例

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

输出样例

9
1234567890005  1 1 1
1234567890014  1 2 1
1234567890001  3 1 2
1234567890003  3 1 2
1234567890004  5 1 4
1234567890012  5 2 2
1234567890002  7 1 5
1234567890013  8 2 3
1234567890011  9 2 4

题意:
有n个考场,每个考场有若干数量的考生。现在给出各个考场中考生的准考证号与分数,
要求将所有考生按分数从高到低排序,并按顺序输出所有考生的准考证号、排名、考场号以
及考场内排名。
思路:
在结构体类型Student中存放题目要求的信息,包括准考证号、分数、考场号、考场内排

名。根据题目要求,这里需要写一个排序函数cmp,规则如下:

①当分数不同时,按分数从大到小排序。
②当分数相同时,按准考证号从小到大排序。
也即写一个类似于下面这段代码的cmp函数:
算法本体则按下面三个步骤进行:
步骤1:按考场读入各考生的信息,并对当前读入考场的所有考生进行排序。之后将该
考场的所有考生的排名写入相应的结构体中。
步骤2:对所有考生进行排序。
步骤3:按顺序一边计算总排名,一边输出所有考生的信息。
注意点:
对同一考场的考生单独排序的方法:定义int型变量num,用来存放当前获取到的考生人
数。每读入一个考生的信息,就让num自增。这样当读取完一个考场的考生信息(假设该考
场有k个考生)后,这个考场的考生所对应的数组下标便为区间[num-k,num)。

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 100010;
struct Student {
    int id;
    int local_rank;
    int sumrank;
    int location;
    int grade;
}stu[maxn];
int n, k;
int num=0; // num为总考生的人数,n为考场数,k为该考场内的人数,因为有多个班,所以有必要用一个num变量储存总人数。
bool cmp(Student a, Student b) {
    if (a.grade != b.grade) {
        return a.grade > b.grade;
    }
    else return a.id < b.id;
}//成绩高,学号靠前者优先
int main()
{
    scanf("%d", &n);
    for (int i = 1; i <= n; i++) {
        scanf("%d", &k);
        for (int j = 0; j < k; j++) {
            scanf("%d%d", &stu[num].id, &stu[num].grade);
            stu[num].location = i;//该学生的考场号为i
            num++;
        }
        sort(stu + num - k, stu + num, cmp);//本考场的学生进行排序
        stu[num-k].local_rank = 1;
        for (int j = num - k+1; j <num; j++) {//num-k+1是该此考场第2名学生,num代表到该考场为止的总人数。
            if (stu[j].grade == stu[j - 1].grade) {
                stu[j].local_rank = stu[i - 1].local_rank;
            }
            else {
                stu[j].local_rank = j + 1-(num-k);//因为local_rank 是本考场的排名所以应该再减去个num-k(之前班里的人数);
            }
        }
    }
    printf("%d\n", num);
    sort(stu, stu + num, cmp);
    stu[0].sumrank = 1;
    for (int i = 1; i < num; i++) {
        if (stu[i].grade == stu[i - 1].grade) {
            stu[i].sumrank = stu[i - 1].sumrank;
        }
        else {
            stu[i].sumrank = i + 1;
        }
    }
    for (int i = 0; i < num; i++) {
        printf("%d %d %d %d\n", stu[i].id, stu[i].sumrank, stu[i].location, stu[i].local_rank);
    }
    return 0;
}

 

标签:Ranking,PAT,int,number,A1025,考场,num,考生,排序
来源: https://www.cnblogs.com/migang/p/14716441.html