codeup|问题 C: 哈夫曼树
作者:互联网
题目描述
哈夫曼树,第一行输入一个数n,表示叶结点的个数。需要用这些叶结点生成哈夫曼树,根据哈夫曼树的概念,这些结点有权值,即weight,题目需要输出所有结点的值与权值的乘积之和。
输入
输入有多组数据。
每组第一行输入一个数n,接着输入n个叶节点(叶节点权值不超过100,2<=n<=1000)。
输出
输出权值。
样例输入 Copy
2
2 8
3
5 11 30
样例输出 Copy
10
62
代码
#include<bits/stdc++.h>
using namespace std;
priority_queue<int, vector<int>, greater<int>> q;
int main() {
int n;
while (scanf("%d", &n) != EOF) {
while (!q.empty()) {//清空数组
q.pop();
}
for (int i = 0; i < n; i++) {
int x;
scanf("%d", &x);
q.push(x);//依次放入优先队列
}
int ans = 0;
while (q.size() > 1) {
int a = q.top();
q.pop();
int b = q.top();
q.pop();
ans += a + b;
q.push(a + b);
}
printf("%d\n", ans);
}
return 0;
}
标签:结点,哈夫曼,int,pop,问题,codeup,ans,输入 来源: https://blog.csdn.net/weixin_43340821/article/details/115311823