【SSL】1040 2004年分区联赛提高组之二 合并果子
作者:互联网
【SSL】1040 2004年分区联赛提高组之二 合并果子
Time Limit:20000MS Memory Limit:65536K
Case Time Limit:5000MS
Description
在一个果园里,多多已经将所有的果子打了下来,而且按果子的不同种类分成了不同的堆。多多决定把所有的果子合成一堆。
每一次合并,多多可以把两堆果子合并到一起,消耗的体力等于两堆果子的重量之和。可以看出,所有的果子经过n-1次合并之后,就只剩下一堆了。多多在合并果子时总共消耗的体力等于每次合并所耗体力之和。
因为还要花大力气把这些果子搬回家,所以多多在合并果子时要尽可能地节省体力。假定每个果子重量都为1,并且已知果子的种类数和每种果子的数目,你的任务是设计出合并的次序方案,使多多耗费的体力最少,并输出这个最小的体力耗费值。
例如有3种果子,数目依次为1,2,9。可以先将1、2堆合并,新堆数目为3,耗费体力为3。接着,将新堆与原先的第三堆合并,又得到新的堆,数目为12,耗费体力为12。所以多多总共耗费体力=3+12=15。可以证明15为最小的体力耗费值。
Input
输入包括两行,第一行是一个整数n(1<=n<=10000),表示果子的种类数。第二行包含n个整数,用空格分隔,第i个整数ai(1<=ai<=20000)是第i种果子的数目。
Output
输出包括一行,这一行只包含一个整数,也就是最小的体力耗费值。输入数据保证这个值小于231。
Sample Input
3
1 2 9
Sample Output
15
Hint
对于30%的数据,保证有n<=1000:
对于50%的数据,保证有n<=5000;
对于全部的数据,保证有n<=10000。
思路
用堆。
先建堆。
堆排序
每次取出堆顶2个,求和,插入堆
代码
手写堆
#include<iostream>
#include<cstdio>
using namespace std;
int h[100010];
class heapmn
{
private:
public:
void heapup(int n,int x);//上移操作,把h[x]上移的合适位置
void heapdown(int n,int x);//下移操作,把h[x]下移的合适位置
void heapinsert(int &n,int x);//插入操作,把x加入堆的合适位置
void heapdelete(int &n,int x);//删除操作,删除h[x]
void heapsort(int &n);//堆排序
void heapbuild(int &n,int m);//建堆
void swap(int &t1,int &t2);//交换两数
};
void heapmn::swap(int &t1,int &t2)//交换两数
{
int t=t1;
t1=t2,t2=t;
return;
}
void heapmn::heapup(int n,int x)//上移操作,把h[x]上移的合适位置
{
if(x>n)return;
for(;x>1;x>>=1)
if(h[x]<h[x>>1]) swap(h[x],h[x>>1]);
else return;
return;
}
void heapmn::heapdown(int n,int x)//下移操作,把h[x]下移的合适位置
{
if(x<1)return;
for(x<<=1;x<=n;x<<=1)
{
x+=(x+1<=n&&h[x+1]<h[x]);
if(h[x]<h[x>>1]) swap(h[x>>1],h[x]);
else return;
}
return;
}
void heapmn::heapinsert(int &n,int x)//插入操作,把x加入堆的合适位置
{
h[++n]=x;
heapup(n,n);
return;
}
void heapmn::heapdelete(int &n,int x)//删除操作,删除h[x]
{
if(h[n]<=h[x]) h[x]=h[n--],heapup(n,x);
else h[x]=h[n--],heapdown(n,x);
return;
}
void heapmn::heapsort(int &n)//堆排序
{
for(;n;h[1]=h[n--],heapdown(n,1))
{
//a[i]=h[1];
printf("%d ",h[1]);
}
return;
}
void heapmn::heapbuild(int &n,int m)//建堆
{
int i;
for(n=0,i=1;i<=m;i++)
{
//h[++n]=a[i];
scanf("%d",&h[++n]);
heapup(n,n);
}
return;
}
int main()
{
heapmn heap;
int n,i,ans=0,tem;
scanf("%d",&n);
heap.heapbuild(n,n);
while(n>1)
{
tem=h[1];
heap.heapdelete(n,1);
tem+=h[1];
ans+=tem;
heap.heapdelete(n,1);
heap.heapinsert(n,tem);
}
printf("%d",ans);
return 0;
}
STL
#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
priority_queue <int> que;
int main()
{
int n,i,ans=0,tem;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&tem);
que.push(-tem);
}
for(i=1;i<n;i++)
{
tem=-que.top();
que.pop();
tem-=que.top();
que.pop();
ans+=tem;
que.push(-tem);
}
printf("%d",ans);
return 0;
}
标签:1040,return,tem,果子,int,void,SSL,2004,heapmn 来源: https://blog.csdn.net/weixin_46975572/article/details/113113541