其他分享
首页 > 其他分享> > 1083 List Grades

1083 List Grades

作者:互联网

1083 List Grades

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:
Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
… …
name[N] ID[N] grade[N]
grade1 grade2
where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

Sample Input 1:
4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100
Sample Output 1:
Mike CS991301
Mary EE990830
Joe Math990112
Sample Input 2:
2
Jean AA980920 60
Ann CS01 80
90 95
Sample Output 2:
NONE

#include<bits/stdc++.h>
using namespace std;
struct node
{
	char name[20];
	char exam[20];
	int score;
};
bool cmp(node a,node b)
{
	return a.score>b.score;
}
int main()
{
	int n,min,max;
	cin>>n;
	vector<node> v(n);
	for(int i=0;i<n;i++){
		cin>>v[i].name>>v[i].exam>>v[i].score;
	}
	int count=0;
	cin>>min>>max;
	for(int i=0;i<n;i++){
		if(v[i].score<min||v[i].score>max){
			v[i].score=-1;
		}
		else{
			count++;
		}
	}
	if(count==0){
		cout<<"NONE\n";
	}
	else{
		sort(v.begin(),v.end(),cmp);
		for(int i=0;i<count;i++){
			cout<<v[i].name<<" "<<v[i].exam<<endl;
		}
	}
	return 0;
}

标签:1083,name,grade,List,int,Grades,score,student,ID
来源: https://blog.csdn.net/xuexiwd/article/details/114763662