其他分享
首页 > 其他分享> > PAT甲级——A1055 The World‘s Richest

PAT甲级——A1055 The World‘s Richest

作者:互联网

题目

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤) - the total number of people, and K (≤) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:
For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50
Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn = 100010;

int Age[maxn] = {0};//年龄数组判定是否为前100人 
struct person{
	int age;
	char name[10];
	int worths;
}ps[maxn],val[maxn];//val为在各自年龄中财富值在100名以内的人

bool cmp(person a, person b){
	if(a.worths != b.worths) return a.worths > b.worths;
	else if(a.age != b.age) return a.age < b.age;
	return strcmp(a.name,b.name) < 0;
} 
int main(){
	int n,k;//总人数,查询次数
	scanf("%d%d",&n,&k);
	for(int i = 0;i < n; i++){
		scanf("%s%d%d",ps[i].name,&ps[i].age,&ps[i].worths);
	} 
	sort(ps,ps+n,cmp);
	int validNum = 0;
	
	
# ①
	for(int i = 0; i < n; i++){
		if(Age[ps[i].age]< 100){
			Age[ps[i].age]++;
			val[validNum++] = ps[i];
		}
	}

## ②
	int m, ageL, ageR;
	for(int i = 1;i <= k;i++){
		scanf("%d%d%d",&m,&ageL,&ageR);
		printf("Case #%d:\n",i);
		int printNum = 0;
		for(int j = 0; j < validNum && printNum < m; j++){
			if(val[j].age >= ageL && val[j].age <= ageR){
				printf("%s %d %d\n",val[j].name,val[j].age,val[j].worths);
				printNum++; 
			}
		}
		if(printNum == 0){
			printf("None\n");
		}
	} 

	return 0;
}

总结

①如何选出每个年龄的前100;设置年龄数组:i:年龄-》Age【i】:i年龄的人数
②如何只输出前m个人:设printNum = 0来计数

标签:ps,PAT,A1055,val,int,age,World,5888,worths
来源: https://blog.csdn.net/weixin_45070743/article/details/113832781