其他分享
首页 > 其他分享> > HDUOJ 2006求奇数的乘积

HDUOJ 2006求奇数的乘积

作者:互联网

HDUOJ 2006求奇数的乘积


Problem Description
给你n个整数,求他们中所有奇数的乘积。

Input
输入数据包含多个测试实例,每个测试实例占一行,每行的第一个数为n,表示本组数据一共有n个,接着是n个整数,你可以假设每组数据必定至少存在一个奇数。

Output
输出每组数中的所有奇数的乘积,对于测试实例,输出一行。

Sample Input
3 1 2 3
4 2 3 4 5

Sample Output
3
15

本题思路很简单,借助数组存储输入的元素,判断是否为奇数并累乘

Submit

#include<stdio.h>

int main(){
	int n,a[99];
	
	while (scanf("%d", &n)!=EOF) {
		int mul = 1;
		for (int i = 0; i < n; i++) {
			scanf("%d", &a[i]);
			if ((a[i] % 2) == 1) {
				mul *= a[i];
			}
		}
		printf("%d\n", mul);
	}
	return 0;
}

标签:乘积,奇数,int,HDUOJ,实例,2006,Input,mul
来源: https://blog.csdn.net/qq_45114168/article/details/113200069