其他分享
首页 > 其他分享> > poj2262 Goldbach's Conjecture

poj2262 Goldbach's Conjecture

作者:互联网

Goldbach's Conjecture

poj2262

题目

Problem Description In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:
Every even number greater than 4 can be
written as the sum of two odd prime numbers.

For example:
8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n. Output For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong." Sample Input
8
20
42
0
Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

题目大意:

验证哥德巴赫猜想:任一大于2的偶数都可写成两个素数之和

解题思路

打出素数表,判断in-i是否是素数。(\(3 \leq i \leq \frac{n}{2}\))

代码

#include <stdio.h>
#include <math.h>
#include <string.h>
#define N 1000010
int n,a[N];
void prime()
{
	int i,j,m;
	memset(a,0,sizeof(a));
	a[0]=a[1]=1;
	for(i=2;i<=N/2;i++)
		if(a[i]==0){
			for(j=2*i;j<=N;j=j+i)
				a[j]=1;	//不是素数 
		}
}
 
int main()
{
	prime();
	int i,flag;
	while(scanf("%d",&n)!=EOF)
	{
		flag=0;
		if(n==0)
			break;
		for(i=3;i<=N/2;i++)
			if(a[i]==0&&a[n-i]==0)
			{
				printf("%d = %d + %d\n",n,i,n-i);
                flag=1;
                break;
			}
		if(flag==0)
			printf("Goldbach's conjecture is wrong.\n");
	}
	return 0;
}

标签:prime,Conjecture,20,Goldbach,poj2262,conjecture,include,odd
来源: https://www.cnblogs.com/Jernewson/p/14327109.html