其他分享
首页 > 其他分享> > nyoj 另类乘法

nyoj 另类乘法

作者:互联网

标题 另类乘法

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, AB is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 12345 is equal to 14 + 15 + 24 + 25 + 34 + 35 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie’s style of multiplication.

输入格式
The first Line of the input is a positive integer T,indicates the number of the test cases;
In every case,the input is in one line,contains two positive interger A,B

输出格式
For every case,output the multiplication in Bessie’s style.

样例
样例输入
1
123 45
样例输出
54

//奇技淫巧,我们用字符串数组来代替整型数组,不需要再对数分解取余。
```c
#include <stdio.h>
#include <string.h>
char a[1000000], b[1000000];
int main()
{
	int n;
	scanf("%d",&n);
	while (n --)
	{
		scanf("%s %s",a, b);
		int la = strlen(a);
		int lb = strlen(b);
		int sum = 0;
		for (int i = 0; i < la; i ++)
		{
			for (int j = 0; j < lb; j ++)
			{
				sum += (a[i] - '0') * (b[j] - '0');
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


标签:style,int,样例,sum,另类,nyoj,multiplication,Bessie,乘法
来源: https://blog.csdn.net/RooKichenn/article/details/110198873