其他分享
首页 > 其他分享> > 【二维树状数组】poj 2155 Matrix

【二维树状数组】poj 2155 Matrix

作者:互联网

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 38085   Accepted: 13627

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1


代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<map>
using namespace std;
const int maxn=1005;
int t,cc[maxn][maxn],n;
int lowbit(int x)
{
    return x&(-x);
}
void add(int x,int y,int v)
{
    for(int i=x;i<=n;i+=lowbit(i))
        for(int j=y;j<=n;j+=lowbit(j))
            cc[i][j]+=v;
}
int query(int x,int y)
{
    int res=0;
    for(int i=x;i>0;i-=lowbit(i))
        for(int j=y;j>0;j-=lowbit(j))
            res+=cc[i][j];
    return res;
}
int main()
{
    freopen("a.in","r",stdin);
    freopen("a.out","w",stdout);
    scanf("%d",&t);
    char e;
    int a,b,c,d,m;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(cc,0,sizeof(cc));
        for(int i=1;i<=m;i++)
        {
            getchar(); e=getchar();
            if(e=='Q')
            {
                scanf("%d%d",&a,&b); a++; b++;
                int ans=query(a-1,b-1);
                printf("%d\n",ans%2);
            }
            if(e=='C')
            {
                scanf("%d%d%d%d",&a,&b,&c,&d); a++; b++; c++; d++;
                add(a-1,b-1,1);
                add(c,d,1);
                add(a-1,d,1);
                add(c,b-1,1);
            }
        }
        if(t) printf("\n");
    }
    return 0;
}

 

标签:Matrix,int,cc,2155,poj,line,include,change,matrix
来源: https://www.cnblogs.com/andylnx/p/14038528.html