其他分享
首页 > 其他分享> > PTA(Advanced Level)1078.Hashing

PTA(Advanced Level)1078.Hashing

作者:互联网

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -
思路
代码
#include<bits/stdc++.h>
using namespace std;
bool used[10010] = {0};

bool is_prime(int x)
{
    if(x <= 1)  return false;
    int up = (int)sqrt(x * 1.0);
    for(int i=2;i<=up;i++)
        if(x % i == 0)
            return false;
    return true;
}   //判断素数的方法

int main()
{
    int table_size, n;
    cin >> table_size >> n;
    if(!is_prime(table_size))
    {
        table_size++;
        while(!is_prime(table_size))
            table_size++;
    }   //检查表长是否为素数

    int t;
    for(int i=0;i<n;i++)
    {
        cin >> t;
        int pos = t % table_size;
        if(used[pos])     //位置被占用就用二次探测法(正向)
        {
            int step = 1;
            int found = false;
            for(;step<table_size;step++)
            {
                pos  = (t + step * step) % table_size;
                if(!used[pos])
                {
                    found = true;
                    break;
                }
            }
            if(found)
            {
                used[pos] = true;
                if(i == 0)
                    cout << pos;
                else
                    cout << " " << pos;
            }else
            {
                if(i == 0)
                    cout << "-";
                else
                    cout << " " << "-";
            }
        }else   //如果位置没有被占用
        {
            used[pos] = true;
            if(i == 0)
                cout << pos;
            else
                cout << " " << pos;
        }

    }
    return 0;
}
引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805389634158592

标签:prime,1078,int,step,table,line,Hashing,Advanced,size
来源: https://www.cnblogs.com/MartinLwx/p/12527511.html