其他分享
首页 > 其他分享> > HDU ACM Steps:Wolf and Rabbit

HDU ACM Steps:Wolf and Rabbit

作者:互联网

HDU ACM Steps:Wolf and Rabbit

题目描述

There is a hill with n holes around. The holes are signed from 0 to n-1.
在这里插入图片描述
A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

输入

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

输出

For each input m n, if safe holes exist, you should output “YES”, else output “NO” in a single line.

输入样例

2
1 2
2 2

输出样例

NO
YES

思路

实际上就是判断m,n是否互质,即c=gcd(m,n)是否为1。

代码

#include<stdio.h>
typedef long long ll;
ll m,n;
ll p;

ll gcd(ll a,ll b)
{
	return b ? gcd(b,a%b):a;
}
int main()
{
	scanf("%d",&p);
	while(p--)
	{
		scanf("%d %d",&m,&n);//2  6
		if(gcd(m,n)==1) printf("NO\n");
		else printf("YES\n");
	}
	
	return 0;
 }

标签:HDU,gcd,get,ll,holes,signed,Steps,Wolf,into
来源: https://blog.csdn.net/weixin_45718149/article/details/104697661