其他分享
首页 > 其他分享> > 安迪的第一个字典

安迪的第一个字典

作者:互联网

Uva 10815 - 安迪的第一个字典

输入一个文本,找出所有不同单词(连续的字母序列),按字典序从小到大输出,不区分大小写。

样例输入:
Adventure in Disneyland.
Two blonds were going to Disneyland when they came to a fork in the road.
The sign read: “Disneyland Left”.
So they went home.
样例输出:(只保留前五行)
a
adventure
blonds
came
disneyland

#include<iostream>
#include<string>
#include<set>
#include<sstream>
using namespace std;

int main()
{
    string s,buf;
    while(cin>>s)
    {
        for(int i=0;i<s.length();i++) //判断是字母还是其他
            if(isalpha(s[i]))
            s[i]=tolower(s[i]);  //转换成小写
            else
                s[i]=' ';
            stringstream ss(s);
            while(ss>>buf)
                dict.insert(buf);
    }
    for(set<string>::iterator it=dict.begin();it!=dict.end();it++)
        cout<<*it<<endl;
    return 0;
}

这个程序我不知道该怎么运行,但是我们可以感受set这一容器的强大。这是算法竞赛入门经典的一道例题。下面有一个可以自己运行的相对简单的题。

单词排序

小红学会了很多英语单词,妈妈为了帮小红加强记忆,拿出纸、笔,把n个单词写在纸上的一行里,让小红看几秒钟后,将这张纸扣在桌子上。妈妈问小红:你能否将这些n个单词按照字典排列的顺序,从小到大写出来?小红按照妈妈的要求写出了答案。现在请你编写程序帮助妈妈检查小红的答案是否正确。注意:所有单词都由小写字母组成,开头字母全都不同,单词两两之间用一个空格分隔。
Input
输入有两行:第一行仅包含一个正整数n
Output
输出仅有一行:针对妈妈写出的单词,按照字典排列的顺序从小到大排成一行的结果,单词两两之间用一个空格分隔。
Sample Input:
4
city boy tree student
Sample Output:
boy city student tree

#include<iostream>
#include<string>
#include<set>
#include<sstream>
using namespace std;
int main()
{
    string s,buf;
    int n;
    cin>>n;
    while(n--)
    {
        cin>>s;
        stringstream ss(s);
        ss>>buf;
        dict.insert(buf);
    }
    for(set<string>::iterator it=dict.begin();it!=dict.end();it++)
        cout<<*it<<" ";
    return 0;
酷毙少男 发布了26 篇原创文章 · 获赞 0 · 访问量 361 私信 关注

标签:第一个,单词,安迪,dict,include,buf,从小到大,字典
来源: https://blog.csdn.net/weixin_43614026/article/details/104101260