其他分享
首页 > 其他分享> > ZZULIOJ 1094: 统计元音(函数专题)

ZZULIOJ 1094: 统计元音(函数专题)

作者:互联网

题目描述

输入一个字符串,统计其中元音字母的个数。要求使用函数vowel()用来判断是否为元音,其余功能在main()函数中实现。 
int vowel(char ch)
{
             //如果ch是元音,返回1,否则返回0
}

本题如果是C/C++代码提交,只需要提交vowel函数的定义部分,提交其它内容,编译出错。

输入

 输入一个字符串,长度不超过1000,以回车符结束。

输出

 输出一个整数,表示元音字母个数。输出单独占一行。

样例输入 

Hello world!

样例输出 

3

tips:

1 元音字母除了 a e i o u 还有 A E I O U

2 getchar()返回当前读取的字符,可以读取回车   scanf()返回读取成功的个数

#include<stdio.h>
#include<stdlib.h>
#include<math.h>

int vowel(char ch)
{
	//如果ch是元音,返回1,否则返回0
	switch (ch)
	{
	case 'a':
	case 'e':
	case 'i':
	case 'o':
	case 'u':
	case 'A':
	case 'E':
	case 'I':
	case 'O':
	case 'U':
		return 1;
		break;
	default:
		return 0;
		break;
	}
}

int main(){
	char ch;
	int count = 0;
	while ((ch=getchar())!='\n')
	{
		count += vowel(ch);
	}
	printf("%d",count);

}

 

马赛克| 发布了122 篇原创文章 · 获赞 58 · 访问量 4万+ 私信 关注

标签:1094,case,ch,int,返回,ZZULIOJ,vowel,元音
来源: https://blog.csdn.net/qq_39112646/article/details/104080510