其他分享
首页 > 其他分享> > HDU 1035 Robot Motion

HDU 1035 Robot Motion

作者:互联网

Robot Motion

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3466    Accepted Submission(s): 1608


Problem Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.  

 

Input There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.  

 

Output For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.  

 

Sample Input 3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0  

 

Sample Output 10 step(s) to exit 3 step(s) before a loop of 8 step(s)  

 

Source Mid-Central USA 1999     解题思路: 按照数组的值走,一步一步模拟,vis[][]储存机器人的步数。   AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int  step=0,row,col,start,flag=0;
char map[20][20];
int vis[20][20];
void search(int x,int y,int step)
{
    if(flag)
        return;
    if(vis[x][y]){
        int cnt=vis[x][y];
        printf("%d step(s) before a loop of %d step(s)\n",cnt-1,step-cnt);
        flag=1;
        return;
    }
    if(x==0||y==0||x>row||y>col){
        printf("%d step(s) to exit\n",step-1);
        return;
        flag=1;
    }
    vis[x][y]=step;
    if(map[x][y]=='N')//n
        search(x-1,y,step+1);
    else if(map[x][y]=='S')//s
        search(x+1,y,step+1);
    else if(map[x][y]=='W')//w
        search(x,y-1,step+1);
    else if(map[x][y]=='E')//e
        search(x,y+1,step+1);
}
int main()
{
    while(cin>>row>>col>>start){
        memset(vis,0,sizeof vis);
        if(row==0&&col==0&&start==0)
            break;
        for(int i=1;i<=row;i++){
            for(int j=1;j<=col;j++){
                cin>>map[i][j];    
            }
        }
        flag=0;
        search(1,start,1);
    }
    return 0;
} 

 

标签:HDU,number,int,robot,Robot,Motion,step,grid,instructions
来源: https://www.cnblogs.com/lovelcy/p/11824891.html