其他分享
首页 > 其他分享> > Strategic game POJ - 1463 【最小点覆盖集】

Strategic game POJ - 1463 【最小点覆盖集】

作者:互联网

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:

the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2。
题意:在无向图中,在某一点放置士兵,该士兵可以守护与该点相邻的其他点,求出要保护所有点的最少士兵数。
思路:求最小点覆盖。。最小点覆盖数 = 最大匹配数
AC代码:
#include <algorithm>
#include <string.h>
#include <cstdio>
#include <vector>

using namespace std;
#define maxn 2500
int vis[maxn];
int match[maxn];
vector<int> v[maxn]; 
int n;
int dfs(int u){ // 匈牙利模板
    for(int i=0;i<v[u].size();i++){
        int temp=v[u][i];
        if(vis[temp]==0){
            vis[temp]=1;
            if(match[temp]==0||dfs(match[temp])){
                match[temp]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main(){
    while(~scanf("%d",&n)){
        for(int i=0;i<=n;i++)
            v[i].clear();
        for(int i=1;i<=n;i++){
            int x,m,y;
            scanf("%d:(%d)",&x,&m);
            for(int j=0;j<m;j++){
                scanf("%d",&y);
                v[x].push_back(y);
                v[y].push_back(x);
            }
        }
        memset(match,0,sizeof(match));
        int ans=0;
        for(int i=0;i<n;i++){
            memset(vis,0,sizeof(vis));
            if(dfs(i))
                ans++;
        }
        printf("%d\n",ans/2);
    }
    return 0;
}

 



标签:node,int,tree,number,Strategic,game,POJ,following,include
来源: https://www.cnblogs.com/pengge666/p/11624407.html