其他分享
首页 > 其他分享> > PATA1055 The World's Richest (25 分)

PATA1055 The World's Richest (25 分)

作者:互联网

1055 The World's Richest (25 分)
Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10^​5) - the total number of people, and K (≤10^​3 ) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10^6,10^6]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:
For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50
Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

技术总结


  1. 想法一:之前想的是,首先建立一个数组结构体然后存下所有的富豪信息,最后再建立K个同样的结构体,用来存放每个年龄段的富豪,再对这个年龄段的富豪排序,输出前M位 。但是这样会超时,也许是时间复杂太高了吧
  2. 想法二:就是首先对富豪,然后对排序后N个富豪中剔除每个年龄100名以后的,因为每一组最多输出前一百名。最后就是输出,直接输出就好了。具体看代码,下面是方法二的代码。

参考代码:

#define _CRT_SECURE_NO_WARNINGS
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAX_N = 100010;
const int MAX_K = 1010;
struct Billionaires {//用于存储人物信息
    char name[10];
    int age;
    int money;
}Billion[MAX_N], rangeB[MAX_N];

int Age[MAX_N] = { 0 };
struct Groups {
    int num;//每一小组的前多少名
    int minage;//最小年龄
    int maxage;//最大年龄
}Group[MAX_K];

//struct Billionaires ;//可以将每一段年龄的人分开到不同的小组中用于排序

//比较函数,用于判断分离年龄后的内部排序
bool cmp(Billionaires a, Billionaires b) {
    int s = strcmp(a.name, b.name);
    if (a.money != b.money) {
        return a.money > b.money;
    }
    else if (a.age != b.age) {
        return a.age < b.age;
    }
    else {
        return s < 0;
    }
}

int main() {
    int N, K;
    scanf("%d%d", &N, &K);
    //信息的读取写入
    for (int i = 0; i < N; i++) {
        scanf("%s%d%d", Billion[i].name, &Billion[i].age, &Billion[i].money);
    }
    for (int i = 0; i < K; i++) {
        scanf("%d%d%d", &Group[i].num, &Group[i].minage, &Group[i].maxage);
    }
    int len = 0;
    
    sort(Billion, Billion + N, cmp);//进行排序所有成员
    int validNum = 0;
    //这个for循环是为了将每个年龄的前一百保留,因为在每个年龄组最多输出一百位
    
    for (int i = 0; i < N; i++) {
        if (Age[Billion[i].age] < 100) {
            Age[Billion[i].age]++;
            rangeB[validNum++] = Billion[i];
        }
    }
    
    for (int i = 0; i < K; i++) {
        printf("Case #%d:\n", i + 1);
        int flag = 0;//用来标记该组是否有输出对象,初始化0表示没有,1表示有输出对象
        int num = 0;//用来记录已输出人数 
        for (int j = 0; num < Group[i].num && j < N; j++) {
            if (rangeB[j].age >= Group[i].minage && rangeB[j].age <= Group[i].maxage) {
                printf("%s %d %d\n", rangeB[j].name, rangeB[j].age, rangeB[j].money);
                flag = 1;
                num++;
            }
        }
        if (flag == 0) {
            printf("None\n");
        }
    }
    system("pause");
    return 0;

}

标签:Billion,25,输出,int,age,PATA1055,++,World,5888
来源: https://www.cnblogs.com/tsruixi/p/11431905.html