魔咒词典 (哈希+二分)
作者:互联网
原题目:
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。
给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:
[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
Sample Input
[expelliarmus] the disarming charm [rictusempra] send a jet of silver light to hit the enemy [tarantallegra] control the movement of one's legs [serpensortia] shoot a snake out of the end of one's wand [lumos] light the wand [obliviate] the memory charm [expecto patronum] send a Patronus to the dementors [accio] the summoning charm @END@ 4 [lumos] the summoning charm [arha] take me to the sky
Sample Output
light the wand accio what? what?
#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<set>
#include<cmath>
#include<stack>
#include<string>
const int maxn=1e5+10;
const int mod=1e9+7;
const int inf=1e8;
#define me(a,b) memset(a,b,sizeof(a))
#define lowbit(x) x&(-x)
#define mid l+(r-l)/2
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define PI 3.14159265358979323846
int dir[4][2]= {0,-1,-1,0,0,1,1,0};
typedef long long ll;
using namespace std;
char str1[maxn][30],str2[maxn][100];
int len=0;
struct node
{
int has,i;
bool friend operator<(node a,node b)
{
return a.has<b.has;
}
}cnt1[maxn],cnt2[maxn];///cnt1保存魔咒的hash值,cnt2保存对应功能的hash值
int gethash(char *str)///算一个字符串的hash值
{
int sum=0,seed=131;
int l=strlen(str);
for(int i=0;i<l;i++)
sum=sum*seed+str[i];
return sum;
}
void solve()///将魔咒和对应功能的字符串转化成相应的hash值
{
for(int i=0;i<len;i++)
{
cnt1[i].has=gethash(str1[i]);
cnt2[i].has=gethash(str2[i]);
cnt1[i].i=cnt2[i].i=i;
}
sort(cnt1,cnt1+len);///排序,方便后面二分查找。
sort(cnt2,cnt2+len);
}
int main()
{
while(scanf("%s",str1[len])&&strcmp(str1[len],"@END@"))
{
getchar();
gets(str2[len++]);
}
solve();
int n;
scanf("%d",&n);
getchar();
for(int i=0;i<n;i++)
{
char str[105];
gets(str);
node temp;
if(str[0]=='[')
{
temp.has=gethash(str);
int pos=lower_bound(cnt1,cnt1+len,temp)-cnt1;///输入的魔咒,在对应数组里面找
if(temp.has==cnt1[pos].has)
printf("%s\n",str2[cnt1[pos].i]);///若有这个魔咒,输出对应的功能
else
printf("what?\n");
}
else
{
temp.has=gethash(str);
int pos=lower_bound(cnt2,cnt2+len,temp)-cnt2;///跟上面原理一样
if(temp.has==cnt2[pos].has)
{
int len=strlen(str1[cnt2[pos].i]);
str1[cnt2[pos].i][len-1]='\0';///这步和下面的+1都是为了不输出那个中括号
printf("%s\n",str1[cnt2[pos].i]+1);
}
else
printf("what?\n");
}
}
return 0;
}
思路:
这个题有两种方法,一种是用STL库里面的map来进行一一对应。或者就是用哈希+二分来解决
先建立两个结构体数组,一个用来保存魔咒的名字的哈希值,另一个来保存魔咒解释的哈希值,
然后输入字符串,先判断是魔咒还是解释,然后新建一个结构体来保存这个魔咒的哈希值,再用二分或者lower_bound函数来进行查找(二分的话有点麻烦,还是不会实现)找到对应的位置并且·输出另一个结构体数组同样位置的解释
标签:二分,what,魔咒,哈希,include,词典,define 来源: https://blog.csdn.net/weixin_43791787/article/details/99216190