PTA乙级1019
作者:互联网
1019
给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174,这个神奇的数字也叫 Kaprekar 常数。
例如,我们从6767开始,将得到
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。
输入格式:
输入给出一个 (0,10
4
) 区间内的正整数 N。
输出格式:
如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000;否则将计算的每一步在一行内输出,直到 6174 作为差出现,输出格式见样例。注意每个数字按 4 位数格式输出。
输入样例 1:
6767
输出样例 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
输入样例 2:
2222
输出样例 2:
2222 - 2222 = 0000
思路:设置两个函数分别表示非递增排列和非递减排列
其中用到了Arrays.sort(a);
来将数组中的数据排序,然后将两函数代入公式中利用do while
循环输出题目要求的计算过程
其中还用了System.out.printf("%04d - %04d = %04d\n",FZ(N),FJ(N),HD);
来使输出的数据保持xxxx-xxxx=xxxx
的形式
package test1;
import java.util.Arrays;
import java.util.Scanner;
public class PTA1019 {
public static void main(String []args){
Scanner in=new Scanner(System.in);
int N=in.nextInt();
int HD = FZ(N)-FJ(N);
if(HD==0){
System.out.printf("%04d - %04d = %04d\n",FZ(N),FJ(N),HD);
}else{
int n ;
do{
n = FZ(N)-FJ(N);
System.out.printf("%04d - %04d = %04d\n",FZ(N),FJ(N),n);
N = n;
}while(n!=6174);
}
}
private static int FZ(int x){//非递增函数
int[]a = new int[4];
a[0] = x/1000;
a[1] = x/100%10;
a[2] = x/10%10;
a[3] = x%10;
Arrays.sort(a);//排序
int N = a[3]*1000+a[2]*100+a[1]*10+a[0];
return N;
}
private static int FJ(int x){//非递减函数
int[]a = new int[4];
a[0] = x/1000;
a[1] = x/100%10;
a[2] = x/10%10;
a[3] = x%10;
Arrays.sort(a);
int N = a[0]*1000+a[1]*100+a[2]*10+a[3];
return N;
}
}
标签:10,int,FZ,04d,PTA,1019,FJ,6174,乙级 来源: https://blog.csdn.net/qq_30039097/article/details/94615586