其他分享
首页 > 其他分享> > poj 1650 Integer Approximation 小数逼近问题 (★☆☆☆☆)

poj 1650 Integer Approximation 小数逼近问题 (★☆☆☆☆)

作者:互联网

http://poj.org/problem?id=1650

题意很简单,给出两个数A (0.1 <= A < 10),L (1 <= L <= 100000),求出这样两个整数N,D(1 <= N, D <= L),要求满足|A - N / D|的值最小。

一看题我就用了暴力搜索,结果竟然超时,有点不可思议,并伴有一点郁闷!!!

看过几篇网上的解题报告,才深刻认识到:我的ACMP-ICPC之路还任重而道远啊!

大体解题思路:令N=D=1,使用while循环,用N/D与A做比较:如果 N/D<A,那么N++;反之,D++。

Sample Input

3.14159265358979
10000

Sample Output

355 113

 

Source Code
#include <iostream>
using namespace std;

int main(){
	double a,tmp,min=16;
	int top,bottom,L,ans_n,ans_d;
	cin>>a>>L;
	top=bottom=1;
	while(top<=L && bottom<=L){
		tmp=(double)top/bottom;
		if(tmp<a){
			if(a-tmp<min){
				min=a-tmp;
				ans_n=top;
				ans_d=bottom;
			}
			top++;
		}
		else{
			if(tmp-a<min){
				min=tmp-a;
				ans_n=top;
				ans_d=bottom;
			}
			bottom++;
		}
	}
	cout<<ans_n<<" "<<ans_d<<endl;
	return 0;
}

转载于:https://www.cnblogs.com/pcwl/archive/2011/04/26/2029412.html

标签:Sample,int,top,Approximation,poj,ans,Integer,1650
来源: https://blog.csdn.net/weixin_34392906/article/details/93986917