其他分享
首页 > 其他分享> > 信息学奥赛 1181:整数奇偶排序

信息学奥赛 1181:整数奇偶排序

作者:互联网

时间限制: 1000 ms         内存限制: 65536 KB

提交数: 23930     通过数: 15560

【题目描述】

给定10个整数的序列,要求对其重新排序。排序要求:

1.奇数在前,偶数在后;

2.奇数按从大到小排序;

3.偶数按从小到大排序。

【输入】

输入一行,包含10个整数,彼此以一个空格分开,每个整数的范围是大于等于0,小于等于30000。

【输出】

按照要求排序后输出一行,包含排序后的10个整数,数与数之间以一个空格分开。

【输入样例】

4 7 3 13 11 12 0 47 34 98

【输出样例】

47 13 11 7 3 0 4 12 34 98
更多信息学奥赛学习资料

链接:https://pan.baidu.com/s/1IBH3uj7OdE6gx16RYxZCtw?pwd=ip6d

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
bool cmp(int a,int b){
    return a>b;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int a[11];
    for(int i=1;i<=10;i++) cin>>a[i];
    sort(a+1,a+11,cmp);
    for(int i=1;i<=10;i++)
        if(a[i]&1) cout<<a[i]<<" ";
    for(int i=10;i>=1;i--)
        if(!(a[i]&1)) 
            cout<<a[i]<<" ";
    return 0;
}

  

标签:11,奇偶,include,10,int,整数,1181,奥赛,排序
来源: https://www.cnblogs.com/sd129/p/16652529.html