其他分享
首页 > 其他分享> > 九度OJ题目1440-Goldbach's Conjecture

九度OJ题目1440-Goldbach's Conjecture

作者:互联网

题目描述:
Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2. 
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the

number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

输入:
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

输出:
Each output line should contain an integer number. No other characters should appear in the output.

样例输入:
6
10
12
0
样例输出:
1
2
1
参考代码:

/*
2^15=32768
*/

#include<cstdio>
#include<iostream>
using namespace std;
#define N 50000

//bool prime[N];
int prime[N];
int primeSize;
bool mark[N];
//筛选素数
void init() {//mark[j]==false是否一定是素数
	memset(prime, false, sizeof prime);
	memset(mark, false, sizeof mark);
	primeSize = 0;
	for (int i = 2; i < N; i++) {
		if (mark[i] == true) continue;
		prime[primeSize++] = i;
		if (i >= 1000) continue;
		for (int j = i*i; j < N; j += i)
			mark[j] = true;
	}
}
int main() {
	int x;
	init();
	while (scanf("%d", &x) != EOF) {
		if (x == 0) break;
		int cnt = 0;
		for (int i = 0; prime[i] <=x / 2; i++) {//必须加等号,因为x的一半也可能为素数
			int j = x - prime[i];
			if (mark[j] == false) {
				//printf("%d,%d\n", prime[i], j);
				cnt++;

			}
		}
		printf("%d\n", cnt);
	}
	return 0;
}

 

标签:prime,even,Conjecture,OJ,int,number,mark,p2,九度
来源: https://blog.csdn.net/sinat_38292108/article/details/88294272