其他分享
首页 > 其他分享> > pat甲级World_Cup_Betting 1011世界杯投注

pat甲级World_Cup_Betting 1011世界杯投注

作者:互联网

原题

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

题目大意

 给出了三场比赛的赔率(65%的正确率),每次投注两元,求最大期望收入以及该情况下的比赛结果。

实现代码

//
// Created by 86185 on 2022/1/30.
//World Cup Betting
#include <stdio.h>
int main() {
    int i,j;
    double sum = 1.3;//sum是最后利润
    double odds[3][3];//倍率
    double odd;
    //将输入数据存入数组
    for ( i = 0; i < 3; i++) {
        for (  j= 0; j < 3; j++) {//将倍率输入
            scanf("%lf", &odd);
            odds[i][j]=odd;
        }
    }

    char a[3] = {'W', 'T', 'L'};//输赢情况
    int max[3] = {0, 0, 0};//赔率最大时的对应下标
    for (i = 0; i < 3; i++) {
        for ( j = 0; j < 3; j++)
        {
            if (odds[i][j]>odds[i][max[i]]){
                max[i]=j;
            }
        }
    }
    for(i=0;i<3;i++){
        sum*=odds[i][max[i]];
    }
    for(i=0;i<3;i++){
        printf("%c ",a[max[i]]);
    }
    sum=sum-2;
    printf("%.2lf",sum);
}

 

标签:pat,Cup,odds,game,each,World,odd,Betting
来源: https://blog.csdn.net/qq_53388188/article/details/122814912