其他分享
首页 > 其他分享> > 【并查集】小希的迷宫 HDU-1272

【并查集】小希的迷宫 HDU-1272

作者:互联网

相较于普通的并查集,这个题里函数的写法体现什么?

具体问题具体分析是马克思主义活的灵魂


这个题要注意的地方很多
但是根子上还是一个并查集而已
千层马甲属于是

至于要注意的地方嘛······
你知道我这一晚上是怎么过的吗??!!

懒得切输入法当时为了调码就英文注释了·······

Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

读到这里,牛人应该发现三个坑点:
1.并查集判环
2.统计根结点数
3.比较恶心的套娃输入(对于我这样的初学者来说)
然而后面还有一点,dalao题解里说到直接输入0 0,
这个我无论如何也意识不到的

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0

-1 -1

Sample Output

Yes
Yes
No

这次收获主要是学到了并查集判环
还有!代码能力提升了!
普通的union函数是void的(在我的认知里)
这个就可以通过布尔返回值体现一个并查集判环
BEAUTIFUL
顺便,do while 写法应该是比较少的

#include<iostream>
using namespace std;
int fa[10000500],a,b,tot;
bool vis[10000500],flag;
void init(){
    for(int i=1;i<=1000000;i++){//initialization
        fa[i]=i;
        vis[i]=0;
    }
}
int find(int x){//an usual find(x)
    if(fa[x]==x) return x;
    else{
        fa[x]=find(fa[x]);
        return fa[x];
    }
    //while(x!=fa[x])
    //    x=fa[x];
    //return x;
}
bool unin(int x,int y){//pay attention to circles
    int rx=find(x);//i mean all points can only connect once
    int ry=find(y);//or there may be circles
    if(rx!=ry){
        fa[rx]=ry;
        return true;
    }//if some point is connecting more than once
    else return false;//return false
}
int main(){
    int cnt=0;
    while(1){
        cnt=0;
        flag=1;
        init();
        do{//consider inputting 0 0 in the begginning
            cnt++;
            if(cnt==1) cin>>a>>b;
            if(a==-1&&b==-1) return 0;
            if(a==0&&b==0){
                cout<<"Yes"<<endl;
                continue;
            }
            vis[a]=1;vis[b]=1;//i have visited a and b
            if(unin(a,b)==false) flag=false;
        }while(cin>>a>>b&&a!=0&&b!=0);//do while MUST be designed for this
        //beautiful
        if(flag==false)cout<<"No"<<endl;
        else{
            tot=0;
            for(int i=1;i<=1000000;i++){
                if(vis[i]&&fa[i]==i){//they may jump over some numbers
                    tot++;//how many father points?
                }
            }
            if(tot==1)cout<<"Yes"<<endl;//if there is only one fa
            //then the DAG is the one we want
            else cout<<"No"<<endl;
        }
    }
    return 0;
}

标签:HDU,查集,并查,1272,房间,迷宫,小希,&&
来源: https://www.cnblogs.com/Jedi-Pz/p/15614130.html