其他分享
首页 > 其他分享> > Just a Hook

Just a Hook

作者:互联网

原题链接:https://acm.dingbacode.com/showproblem.php?pid=1698

Problem Description:

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.


Input:

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output:

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.


Sample Input:

1
10
2
1 5 2
5 9 3

Sample Output:

Case 1: The total value of the hook is 24.

解题思路:

线段树模板题,本题包含建树、向上回溯、区间修改、区间查询、向下推

AC代码:

#include<iostream>
using namespace std;
#define n 100000
int T, N, Q;						//测试数据组数T、钩子的钢棒数N、操作Q
int lazy[n * 4];
int tree[n * 4];				        //定义线段树数组
int a, b, level, sum;
void pushup(int node)					//所有父结点的值为子树值的和
{
	tree[node] = tree[node * 2] + tree[node * 2 + 1];
}
void pushdown(int node, int m)
{
	if (lazy[node])
	{
		lazy[node * 2] = lazy[node];
		lazy[node * 2 + 1] = lazy[node];
		tree[node * 2] = lazy[node] * (m - (m / 2));
		tree[node * 2 + 1] = lazy[node] * (m / 2);
		lazy[node] = 0;
	}
}
void build(int l, int r, int node)		      //建树
{
	lazy[node] = 0;
	if (l == r)
	{
		tree[node] = 1;
		return;
	}
	int mid = (l + r) / 2;
	build(l, mid, node * 2);
	build(mid + 1, r, node * 2 + 1);
	pushup(node);
}

void update(int a, int b, int level, int l, int r, int node) 
{                                                //更改区间 更改至c
	if (a <= l && r <= b) {			// l,r 树的区间  
		lazy[node] = level;
		tree[node] = (int)level * (r - l + 1);
		return;
	}
	pushdown(node, r - l + 1);
	int m = (l + r) / 2;
	if (a <= m) {
		update(a, b, level, l, m, node * 2);
	}
	if (b > m) {
		update(a, b, level, m+1, r, node * 2 + 1);
	}
	pushup(node);
}
int main()
{
	ios::sync_with_stdio(0);
	cin.tie(0);
	cin >> T;						//测试数据组数T
	for (int i = 1; i <= T; i++)
	{
		cin >> N;					//钢棒数N
		cin >> Q;					//操作数Q
		build(1, N, 1);
		for (int i = 0; i < Q; i++)
		{
			cin >> a >> b >> level;
			update(a,b,level, 1, N, 1);		//进行钩子升级	
		}
		printf("Case %d: The total value of the hook is %d.\n",i,tree[1]);
	}
	return 0;
}

标签:node,lazy,Just,hook,int,value,Hook,each
来源: https://www.cnblogs.com/baiye-y/p/15569418.html