其他分享
首页 > 其他分享> > 【高斯消元】POJ1222-EXTENDED LIGHTS OUT

【高斯消元】POJ1222-EXTENDED LIGHTS OUT

作者:互联网

Description

In an extended version of the game Lights Out, is a puzzle with \(5\) rows of \(6\) buttons each (the actual puzzle has \(5\) rows of \(5\) buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of \(3\) buttons; buttons on an edge change the state of \(4\) buttons and other buttons change the state of \(5\). For example, if the buttons marked \(X\) on the left below were to be pressed,the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display. Note that the buttons in row \(2\) column \(3\) and row \(2\) column \(5\) both change the state of the button in row \(2\) column \(4\),so that, in the end, its state is unchanged.

Note:

  1. It does not matter what order the buttons are pressed.
  2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
  3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
    four rows may be turned out. Similarly, by pressing buttons in columns \(2\), \(3\) , \(?\), all lights in the first \(5\) columns may be turned off.
    Write a program to solve the puzzle.

Input

The first line of the input is a positive integer \(n\) which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six \(0\) or \(1\) separated by one or more spaces. A \(0\) indicates that the light is off, while a \(1\) indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, \(1\)'s indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each \(0\) or \(1\) in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

Source

Greater New York 2002

题意

有一个\(5*6\) 的开关阵列和灯,如果按下\((i,j)\)个开关,则它对应灯和它四周相邻的灯的状态都会反转(亮变暗,暗变亮),给出灯的初始状态,问是否可能使得所有灯都熄灭,如果可能给出一个方案

思路

(emo老师上课笔记)

首先可以发现,如果有这样一个方案,那么这个方案中的每一个开关都只需要按一次就好了,按两次会返回原来的状态,是没有意义的。设每个灯的状态暗是0,亮是1.

每次按一个开关,就相当于把这个开关附近的所有的0,1亦或上一个1(亦或两个1相当于亦或1个0,也就是按两次开关没有意义)。令\(x_{ij}\)表示模2的一个等价类(只有0,1),\(x_{ij} = 1\)表示按了开关,\(x_{ij} = 0\)表示没按开关。

最终状态是灯全0,设灯的初始状态是\(a_{ij}\),则由灯附近的开关状态会影响到自身可得出这样一个式子:

\(a_{i,j}\)^\(x_{i,j}\) ^\(x_{i-1,j}\) ^ \(x_{i+1,j}\) ^ \(x_{i,j -1}\) ^ \(x_{i,j + 1}\) $ = 0$

两边同时亦或\(a_{i,j}\)

\(x_{i,j}\) ^\(x_{i-1,j}\) ^ \(x_{i+1,j}\) ^ \(x_{i,j -1}\) ^ \(x_{i,j + 1}\) = \(a_{i,j}\)

亦或跟模2等价类下的加法是不加区分的,就可以写成

\(x_{i,j} + x_{i-1,j} + x_{i+1,j} + x_{i,j -1} + x_{i,j + 1} = a_{i,j} mod 2\)

这样我们就得到了一个关于\(x\)的方程,现在有30盏灯也就得到了30个变量,30个方程。

相当于把这个问题化为,是否存在这样的一个\(X\)使得关于\(x\)的方程乘上\(X\) = 0

相当于,把这个问题进行线性方程组的建模

AC代码

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <iostream>
#define int long long
using namespace std;
typedef vector<int> v;
typedef vector<v> matrix;
matrix ans(30, v(31));//构造矩阵
int t;
void gauss() {
	for (int i = 0; i < 30; i ++) {
		int judge = i;
		for (; judge < 30; judge++) {//查找非0项
			if (ans[judge][i]) break;
		}
		swap(ans[i], ans[judge]);//交换
		for (int j = 0; j < 30; j ++) {//消元
			if (i != j && ans[j][i]) {//亦或0不改,亦或1要改
				for (int k = 0; k <= 30; k ++) {
					ans[j][k] = ans[i][k] ^ ans[j][k];
				}
			}
		}
	}
}

void solve() {
	for (int i = 0; i < 5; i ++) {
		for (int j = 0; j < 6; j ++) {
			cin >> ans[i * 6 + j][30];
			ans[i * 6 + j][i * 6 + j] = 1;
			if (j >= 1) ans[i * 6 + j][i * 6 + j - 1] = 1;
			if (i >= 1) ans[i * 6 + j][i * 6 + j - 6] = 1;
			if (j < 5) ans[i * 6 + j][i * 6 + j + 1] = 1;
			if (i < 4) ans[i * 6 + j][i * 6 + j + 6] = 1;
		}
	}
	gauss();
	for (int i = 0; i < 5; i ++) {
		for (int j = 0; j < 6; j ++) {
			if(j != 5) cout << ans[i * 6 + j][30] << " ";
			else cout << ans[i * 6 + j][30] << endl;
		}
	}
	return;
}
signed main() {
	ios::sync_with_stdio(false);
	cin.tie(0); cout.tie(0);
	while (cin >> t) {
		for(int i = 1;i <= t;i ++){
			cout << "PUZZLE #" << i << endl;
			solve();
		}
	}
	return 0;
}

标签:EXTENDED,int,puzzle,30,buttons,LIGHTS,pressed,ans,高斯消
来源: https://www.cnblogs.com/peace0218/p/15557757.html