其他分享
首页 > 其他分享> > C - The Frog‘s Games

C - The Frog‘s Games

作者:互联网

The annual Games in frogs’ kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog’s longest jump distance).
Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
Output
For each case, output a integer standing for the frog’s ability at least they should have.

Sample Input
6 1 2
2
25 3 3
11
2
18

Sample Output
4
11

题目大意:
青蛙跳石头过河,最多跳m步,问青蛙至少拥有的跳跃能力(一步跳多远)。

解题思路:

完整代码:

#include<iostream>
using namespace std;
int main() {
	int n,n2;
	int a[100010];
	int ma=0;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>a[i];
		ma=max(ma,a[i]);
	}
	cin>>n2;
	if(n2==1){
		cout<<ma<<endl;
		return 0;
	}
	int l=0,r=ma,m;
	while(r>l){
		m=(r+l)/2;
		long long sum=0;
		for(int i=0;i<n;i++){
			if(a[i]>m){
				sum+=(a[i]-m)/(n2-1)+((a[i]-m)%(n2-1)!=0);
			}
		}
		if(sum>m){
			l=m+1;
		}else{
			r=m;
		}
	}
	cout<<l;
}

标签:case,ma,int,sum,Frog,Games,跳跃,n2
来源: https://blog.csdn.net/weixin_52115456/article/details/120581243