其他分享
首页 > 其他分享> > PAT (Advanced Level) 1045 Favorite Color Stripe(LCS,非降序)

PAT (Advanced Level) 1045 Favorite Color Stripe(LCS,非降序)

作者:互联网

1045 Favorite Color Stripe (30 分)  

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤104) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
  结尾无空行

Sample Output:

7
  结尾无空行    
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
    public static void main(String[] args) throws IOException {
        BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
        String s = reader.readLine();
        int N = Integer.parseInt(s);        //N种颜色
        String s1 = reader.readLine();
        String[] s2 = s1.split(" ");
        int M = Integer.parseInt(s2[0]);
        int[] favorite = new int[M];       //最喜欢的颜色序列
        for (int i = 0; i < M; i++) {
            favorite[i] = Integer.parseInt(s2[i + 1]);
        }

        String s3 = reader.readLine();
        String[] s4 = s3.split(" ");
        int L = Integer.parseInt(s4[0]);
        int[] gaven = new int[L];         //给定条纹
        for (int i = 0; i < L; i++) {
            gaven[i] = Integer.parseInt(s4[i + 1]);
        }

        System.out.println(maxLongCommonSubsquence(favorite, gaven, M, L));
    }

    public static int maxLongCommonSubsquence(int[] arr1, int[] arr2, int n1, int n2){
        int[][] dp = new int[n1 + 1][n2 + 1];

        for (int i = 1; i <= n1; i++) {
            for (int j = 1; j <= n2; j++){
                int max = Math.max(dp[i - 1][j], dp[i][j - 1]);
                if (arr1[i-1] == arr2[j-1]){
                    dp[i][j] = max + 1;
                }else {
                    dp[i][j] = max;
                }
            }
        }
        return dp[n1][n2];
    }
}

  

标签:PAT,LCS,1045,int,favorite,colors,her,stripe,String
来源: https://www.cnblogs.com/jasonXY/p/15171943.html