其他分享
首页 > 其他分享> > HDU-1062-Text Reverse(栈)

HDU-1062-Text Reverse(栈)

作者:互联网

题目

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output
hello world!
I’m from hdu.
I like acm.

解题思路:

创建一个栈每输入一个字符就存入栈,当遇到空格或者换行时将栈中的字符全部输出

完整代码

#include<iostream>
#include<stack> 
using namespace std;
int main()
{
	int n,m,i,j;
	char ch;
	cin>>n;
	getchar();
	while(n--)
	{
		stack<char>s;
		while(true)
		{
			ch = getchar();
			
			if(ch==' '||ch=='\n')
			{
				while(!s.empty())
				{
					cout<<s.top();
					s.pop();
				}
				if(ch=='\n')
				break;
				cout<<" ";
			}
			else
			{
				s.push(ch);
			}
		}
		cout<<"\n"; 
	}
	return 0;
}

标签:HDU,ch,Text,1062,single,words,test,line,cases
来源: https://blog.csdn.net/m0_56861113/article/details/119484840