其他分享
首页 > 其他分享> > (hnust 1601)名字缩写(map存储前缀)

(hnust 1601)名字缩写(map存储前缀)

作者:互联网

时间限制: 1 Sec 内存限制: 128 MB
提交: 290 解决: 81
[提交][状态][讨论版]
题目描述
Noname老师有一个班的学生名字要写,但是他太懒了,想少写几个字母。很快他发现这是可行的,例如下面的学生名单:

Davidson
Davis
Dixon
Smith
可以缩写为
David
Davis
Di
S
David 指明Davidson外,不可能是其他三位同学名字的前缀。S仅能代表Smith。在确保能无歧义指明同学的前提下,Noname老师总是希望使用最少的字母。
输入
给定一系列名字,每个名字一行(不超过100行),名字仅含英文字母,名字长度不超过40,这些名字按字母升序排列, 任意两个名字不相同而且一个名字不会正好是另一个名字的前缀。

输出
每行输入对应一行输出,内容为空格分开原来的名字和缩写后的名字。

样例输入
Adams
Andersen
Anderson
Carson
Carter
Carville
Cooper
Coply
Smith
Smythe
Sorensen
Sorenson
Wynn
样例输出
Adams Ad
Andersen Anderse
Anderson Anderso
Carson Cars
Carter Cart
Carville Carv
Cooper Coo
Coply Cop
Smith Smi
Smythe Smy
Sorensen Sorense
Sorenson Sorenso
Wynn W
提示
来源
2014湖南科技大学校赛

分析:看到这个直接想着暴力,但是要求输出名字的前缀且不会重复,那么联系到以前的一个题,直接用map存储所有前缀,然后检验是否出现过,没有的话就直接输出。
需要注意的是只有一个名字的时候,错了一次,因为我写的map存储,存储的第一个字符串是空串,稍微改一点就行了

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<string>
#include<map>
using namespace std;
#define mem(a,n) memset(a,n,sizeof(a))
const int INF=0x3f3f3f3f;
const int N=10;
map<string,int>mp;
int n;
char str[105][45];
bool check(char *s,string str)
{
    for(int i=0,j=0;i<str.length();i++,j++)
        if(str[i]!=s[j])
        return false;
    return true;
}
void solve()
{
    map<string,int>::iterator it=mp.begin();
    int i=0;
    for(it++;it!=mp.end();it++)///因为map存储的第一个字符串是空串,把这里的迭代器+1就可以 了
    {
        if(i==n) break;
        if(it->second==1&&check(str[i],it->first))
            cout<<str[i++]<<" "<<it->first<<"\n";
    }
}
int main()
{
    n=0;
    while(scanf("%s",str[n])!=EOF)
    {
        int len=strlen(str[n]);
        for(int i=0;i<len;i++)
        {
            char ch=str[n][i];
            str[n][i]='\0';
            mp[(string)str[n]]++;
            str[n][i]=ch;
        }
        mp[(string)str[n]]++;
        n++;
    }
    solve();
    return 0;
}

 

标签:map,前缀,1601,Smith,int,名字,hnust,include
来源: https://blog.51cto.com/u_13696685/2990208