其他分享
首页 > 其他分享> > PTA(Advanced Level)1054.The Dominant Color

PTA(Advanced Level)1054.The Dominant Color

作者:互联网

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

思路

代码

#include<bits/stdc++.h>
using namespace std;
map<int, int> image;
int main()
{
	int m, n;
    cin >> m >> n;
	int t;
	for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		{
			scanf("%d", &t);    // 这里使用cin会超时噢!
			if(image.count(t) == 0)		// 统计为0说明是第一次遇到这个数字
				image[t] = 1;
			else
				image[t]++;
		}
	int half = m * n / 2;
	map<int, int>::iterator it;
	for(it=image.begin();it!=image.end();it++)
		if(it->second > half)
		{
			cout << it->first;
			break;
		}
	return 0;
}

引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805422639136768

标签:24,Dominant,Level,Color,image,color,int,each,dominant
来源: https://www.cnblogs.com/MartinLwx/p/12824386.html