pat1016 部分A+B
作者:互联网
1016 部分A+B (15 分)
正整数 A 的“D
A
(为 1 位整数)部分”定义为由 A 中所有 D
A
组成的新整数 P
A
。例如:给定 A=3862767,D
A
=6,则 A 的“6 部分”P
A
是 66,因为 A 中有 2 个 6。
现给定 A、D
A
、B、D
B
,请编写程序计算 P
A
+P
B
。
输入格式:
输入在一行中依次给出 A、D
A
、B、D
B
,中间以空格分隔,其中 0<A,B<10
10
。
输出格式:
在一行中输出 P
A
+P
B
的值。
输入样例 1:
3862767 6 13530293 3
输出样例 1:
399
输入样例 2:
3862767 1 13530293 8
输出样例 2:
0
应该注意返回值,之前返回值是double,用了pow()函数,测试点2一直过不了,把返回值改为int,不用pow()函数之后就通过了。
#include<iostream>
#include<string.h>
using namespace std;
int str(string a,int da)
{
int count=1;
int result=0;
for(int i=0;i<a.length();i++)
if(a[i]-'0'==da)
{
result+=count*da;
count*=10;
//cout<<result<<endl;
}
return result;
}
int main()
{
string a,b;
int da,db;
int n,m;
cin>>a>>da>>b>>db;
n=str(a,da);
m=str(b,db);
cout<<n+m<<endl;
return 0;
}
标签:3862767,int,样例,da,str,返回值,部分,pat1016 来源: https://blog.csdn.net/qq_43526805/article/details/98512900