弹簧板
作者:互联网
弹簧板
题目描述
输入
输出
输出一个整数,表示小球被弹起的次数。
样例输入1
5
2 2 3 1 2
样例输出1
2
样例输入2
5
1 2 3 1 2
样例输出2
4
做法1
#include <bits/stdc++.h>
using namespace std;
int main() {
int n;
cin >> n;
vector<int> a(n);
for (int i = 0; i < n; ++i) {
cin >> a[i];
}
int cnt = 0, pos = 0;
/* 共计n个弹簧板 即弹射总距离超过n时结束此过程 */
while (pos < n) {
/* 从当前弹簧板弹起 次数加1 */
++cnt;
/* 将位置切换到新的弹簧板 */
pos += a[pos];
}
cout << cnt << endl;
return 0;
}
标签:输出,int,样例,pos,弹簧,输入 来源: https://blog.csdn.net/qq_46118239/article/details/117163812