其他分享
首页 > 其他分享> > HDU1701 ACMer【水题】

HDU1701 ACMer【水题】

作者:互联网

ACMer
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6539 Accepted Submission(s): 3086

Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?

Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.

Output
For each test case, output the minumal number of students in HDU.

Sample Input
1
13.00 14.10

Sample Output
15

Source
2007省赛集训队练习赛(1)

问题链接HDU1701 ACMer
问题简述:(略)
问题分析:水题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* HDU1701 ACMer */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int t;
    scanf("%d", &t);
    while (t--) {
        double p, q;

        scanf("%lf%lf", &p, &q);

        int ans;
        for (ans = 1; ; ans++)
            if ((int) (p * ans / 100) < (int) (q * ans / 100)) break;

        printf("%d\n", ans);
    }

    return 0;
}

标签:HDU,水题,int,HDU1701,ACMer,ans,test
来源: https://blog.csdn.net/tigerisland45/article/details/117139195