其他分享
首页 > 其他分享> > PAT 1075.PAT Judge

PAT 1075.PAT Judge

作者:互联网

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤), the total number of users, K (≤), the total number of problems, and M (≤), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.(partial_score_obtained要么是−1(如果提交甚至不能通过编译器),要么是[0,p[problem_id]]范围内的整数。一行中的所有数字都用空格隔开。)

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

 

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 10010;
struct student {
    int id;//准考证号
    int score[6];//每道题的得分
    bool flag;//是否有能通过编译的提交
    int score_all;
    int solve;
}stu[maxn];
int n, k, m;
int user_id, problem_id, partial_score_obtained;
int full[6];
bool cmp(student a, student b) {//排序函数
    if (a.score_all != b.score_all) return a.score_all > b.score_all;
    else if (a.solve != b.solve) return a.solve > b.solve;
    else if (a.id != b.id) return a.id < b.id;
}
void init() {//初始化函数
    for (int i = 1; i <=n; i++) {
        stu[i].id = i;
        stu[i].score_all = 0;
        stu[i].solve = 0;
        stu[i].flag = false;
        memset(stu[i].score,-1,sizeof(stu[i].score));//如果一道题从未有提交记录则其始终为-1.
    }
}
int main() {
    scanf("%d%d%d", &n, &k, &m);//n是考试人数,k是题目个数,m是提交记录
    for (int i = 1; i <=k; i++) {
        scanf("%d", &full[i]);
    }
    init();
    for (int i = 0; i < m; i++) {
        scanf("%d%d%d", &user_id, &problem_id, &partial_score_obtained);
        if (partial_score_obtained!=-1) {
            stu[user_id].flag = true;
        }
        if (partial_score_obtained ==-1 && stu[user_id].score[problem_id]==-1) {//第一次编译错误
            stu[user_id].score[problem_id] = 0;
        }
        if (partial_score_obtained==full[problem_id]&&stu[user_id].score[problem_id]<full[problem_id]) {//第一次获得满分
            stu[user_id].solve++;
        }
        if (partial_score_obtained>stu[user_id].score[problem_id]) {
            stu[user_id].score[problem_id] = partial_score_obtained;
        }
    }
    for (int i = 1; i <= n; i++) {
        for (int j = 1; j <= k; j++) {
            if(stu[i].score[j]!=-1)
            stu[i].score_all += stu[i].score[j];
        }
    }
    sort(stu + 1, stu + n+1, cmp);//stu+n+1为最后一个排序元素的下一个位置
    int r = 1;//r表示排名。
    for (int i = 1; (i <= n) && (stu[i].flag == true); i++) {
        if (i> 1 && stu[i].score_all != stu[i - 1].score_all) {
            r = i;
        }
        printf("%d %05d %d", r, stu[i].id, stu[i].score_all);
        for (int j = 1; j <= k; j++) {
            if (stu[i].score[j] == -1) {
                printf(" -");
            }
            else {
                printf(" %d", stu[i].score[j]);
            }
        }
        printf("\n");
    }
    return 0;
}

 

标签:25,PAT,int,1075,score,user,Judge,problem,id
来源: https://www.cnblogs.com/migang/p/14765536.html