其他分享
首页 > 其他分享> > 015-poj1184聪明的打字员

015-poj1184聪明的打字员

作者:互联网

poj 1184 聪明的打字员

阿兰是某机密部门的打字员,她现在接到一个任务:需要在一天之内输入几百个长度固定为6的密码。当然,她希望输入的过程中敲击键盘的总次数越少越好。

不幸的是,出于保密的需要,该部门用于输入密码的键盘是特殊设计的,键盘上没有数字键,而只有以下六个键:Swap0, Swap1, Up, Down, Left, Right,为了说明这6个键的作用,我们先定义录入区的6个位置的编号,从左至右依次为1,2,3,4,5,6。下面列出每个键的作用:

当然,为了使这样的键盘发挥作用,每次录入密码之前,录入区总会随机出现一个长度为6的初始密码,而且光标固定出现在1号位置上。当巧妙地使用上述六个特殊键之后,可以得到目标密码,这时光标允许停在任何一个位置。

现在,阿兰需要你的帮助,编写一个程序,求出录入一个密码需要的最少的击键次数。

Input

仅一行,含有两个长度为6的数,前者为初始密码,后者为目标密码,两个密码之间用一个空格隔开。

Output

仅一行,含有一个正整数,为最少需要的击键次数。

Sample Input
123456 654321
Sample Output
11

解答

题意:用最少的操作次数转换给定序列到目标序列。

六种操作:

技巧:有6位,同一个数每位只会执行一次,所以状态表示某一维度为6。因为Bfs的特点是会把所有操作可能都入队,所以再次来到这个数的这个位时,已然是做了所有能做的功夫了。

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>

using namespace std;

int pos[6]={100000,10000,1000,100,10,1};//进制
bool v[1000005][6];//某数某位是否操作过
int target,tar[6];//target目标数组,tar辅助输入
struct node
{
    int num;
    int cursor;//在哪位操作
    int step;//操作数量
    node(int n,int c,int s):num(n),cursor(c),step(s){}
};
node n(0,0,0);//起始状态

int swap(int num,int p1,int p2)//交换num的p1和p2位
{
    int v1=(num/pos[p1])%10;//找出p1位
    int v2=(num/pos[p2])%10;
    num += (v2-v1)*pos[p1];//p1的新变化
    num += (v1-v2)*pos[p2];
    return num;
}

int up(int num,int p)//增加num的p位
{
    return num+pos[p];
}

int down(int num,int p)
{
    return num-pos[p];
}

int bfs()
{
    memset(v,false,sizeof(v));
    queue<node> q;
    q.push(n);
    while(!q.empty())
    {
        node t=q.front();q.pop();
        int num=t.num,cursor=t.cursor,step=t.step;
        if(num==target) return step;
        step++;
        //两种交换操作
        if(cursor!=0)
        {
            int temp=swap(num,0,cursor);
            if(!v[temp][cursor])
            {
                q.push({temp,cursor,step});
                v[temp][cursor]=true;
            }
        }
        if(cursor!=5)
        {
            int temp=swap(num,5,cursor);
            if(!v[temp][cursor])
            {
                q.push({temp,cursor,step});
                v[temp][cursor]=true;
            }
        }
        int val=(num/pos[cursor])%10;//当前位值
        //增加和减少
        if(val !=9 && val!=tar[cursor])
        {
            int temp=up(num,cursor);
            if(!v[temp][cursor])
            {
                q.push({temp,cursor,step});
                v[temp][cursor]=true;
            }
        }
        if(val!=0&&val!=tar[cursor])
        {
            int temp=down(num,cursor);
            if(!v[temp][cursor])
            {
                q.push({temp,cursor,step});
                v[temp][cursor]=true;
            }
        }
        //左移右移,交换的时候特判了0和5,这里要考虑进来
        if(cursor!=0&&(val==tar[cursor]||cursor==5))
        {
            if(!v[num][cursor-1])
            {
                q.push({num,cursor-1,step});
                v[num][cursor-1]=true;
            }
        }
        if(cursor!=5&&(val==tar[cursor]||cursor==0))
        {
            if(!v[num][cursor+1])
            {
                q.push({num,cursor+1,step});
                v[num][cursor+1]=true;
            }
        }
    }
    return -1;
}

int main()
{
    char a[10],b[10];
    scanf("%s %s",a,b);
    for(int i=0;i<6;i++)
    {
        tar[i]=a[i]-'0';
        n.num += tar[i]*pos[i];
    }
    for(int i=0;i<6;i++)
    {
        tar[i]=b[i]-'0';
        target += tar[i]*pos[i];
    }
    printf("%d\n",bfs());
}

标签:temp,int,poj1184,cursor,打字员,step,num,015,光标
来源: https://www.cnblogs.com/maxing1997/p/14742746.html