其他分享
首页 > 其他分享> > 天梯赛L1-080 乘法口诀数列 (20 分)

天梯赛L1-080 乘法口诀数列 (20 分)

作者:互联网

L1-080 乘法口诀数列 (20 分)
在这里插入图片描述

输入样例:

2 3 10

输出样例:

2 3 6 1 8 6 8 4 8 4

样例解释:
数列前 2 项为 2 和 3。从 2 开始,因为 2×3=6,所以第 3 项是 6。因为 3×6=18,所以第 4、5 项分别是 1、8。依次类推…… 最后因为第 6 项有 6×8=48,对应第 10、11 项应该是 4、8。而因为只要求输出前 10 项,所以在输出 4 后结束。

用vector做,很比较灵活和简单

#include <iostream>
#include <vector>
#include <string>
using namespace std;
int main()
{
	vector<int> vt;
	int a1, a2;
	int len;
	int result;
	int count = 2;
	int i = 1;
	cin >> a1 >> a2 >> len;
	vt.push_back(a1);
	vt.push_back(a2);
	while (true)
	{
		
		if (count >= len)
			break;
		result = a1 * a2;
		if (result < 10)
		{
			vt.push_back(result);
			count++;
		}
		else
		{
			string str = to_string(result);
			for (int i = 0; i < str.length(); i++)
			{
				int num = str[i] - '0';
				vt.push_back(num);
				count++;
			}
			
		}
		a1 = vt[i];
		a2 = vt[i + 1];
		i++;
	}
	for (int i = 0; i < len; i++)
		if (i != len-1)
			cout << vt[i] << " ";
		else
			cout << vt[i];
	return 0;
}

标签:20,int,080,len,a1,a2,vt,result,L1
来源: https://blog.csdn.net/weixin_50026222/article/details/116323241