其他分享
首页 > 其他分享> > 1003 Emergency (25 分)

1003 Emergency (25 分)

作者:互联网

1003 Emergency (25 分)
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C
​1
​​ and C
​2
​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c
​1
​​ , c
​2
​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C
​1
​​ to C
​2
​​ .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C
​1
​​ and C
​2
​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4

#include<iostream>
#include<vector>
#include<algorithm>
#define INF 0x3f3f3f3f//无穷大
using namespace std;
struct node{
    int v,dis;//点到点的顶点和边权
}ch;
int n,m,a,b;
int num[505];//最短路径条数
int w[505],ww[505];//城市的救援队人数,ww[]城市救援队人数,w[]最大救援队人数
vector<node>d[505];//点到点
int dd[505];//起点到达各点的最短长度
bool vis[505]={false};//城市访问
void Dijkstra (int s){
    fill(dd,dd+505,INF);
    dd[s] = 0;
    for (int i=0;i<n;i++){
        int u=-1,Min = INF;
        for (int j=0;j<n;j++){
            if (vis[j]==false&&dd[j]<Min){
                u=j;
                Min = dd[j];
            }
        }
        if (u==-1) return;//如果找不到下个城市就结束(这里如果考虑的话,一定要初始化第一个点能直接去的其他点的路径)
        //如果不初始化最后一个点就会错,当然也可以直接删掉这行,因为题目说了一定有解
        vis[u]=true;//找过了记一下
        for (int j=0;j<d[u].size();j++){//在接下来能去的城市里找
            int v=d[u][j].v;
            if (vis[v]==false){
                if (d[u][j].dis+dd[u]<dd[v]){
                    dd[v]=dd[u]+d[u][j].dis;//优化最短距离
                    w[v]=w[u]+ww[v];//救援队人数更新
                    num[v]=num[u];//更新路径数量
                }//下同
                else if (d[u][j].dis+dd[u]==dd[v]){
                    num[v]+=num[u];
                    if (w[u]+ww[v]>w[v]) {
                        w[v]=w[u]+ww[v];
                    }
                }
            }
        }
    }
}

void DU(){
    cin>>n>>m>>a>>b;
    for (int i=0;i<n;i++){
        cin>>ww[i];
    }
    int city1,city2,space;
    for (int j=0;j<m;j++){
        cin>>city1>>city2>>space;
        ch.v=city2;
        ch.dis=space;
        d[city1].push_back(ch);
        ch.v=city1;
        d[city2].push_back(ch);
    }
}

int main()
{
    DU();//读入数据
    w[a]=ww[a];//起始点的救援队
    num[a]=1;//自己到自己就一个路
    // for (int i=0;i<d[a].size();i++){
    //     int v=d[a][i].v;
    //     dd[v]=d[a][i].dis;
    // }//初始化第一个点能去的城市
    Dijkstra(a);//算法
    cout<<num[b]<<" "<<w[b]<<endl;
    return 0;
}

标签:25,ch,Emergency,int,dd,ww,num,505,1003
来源: https://blog.csdn.net/weixin_51771856/article/details/115795747