其他分享
首页 > 其他分享> > L1-039 古风排版 (20 分)

L1-039 古风排版 (20 分)

作者:互联网

中国的古人写文字,是从右向左竖向排版的。本题就请你编写程序,把一段文字按古风排版。

输入格式:

输入在第一行给出一个正整数N(<100),是每一列的字符数。第二行给出一个长度不超过1000的非空字符串,以回车结束。

输出格式:

按古风格式排版给定的字符串,每列N个字符(除了最后一列可能不足N个)。

输入样例:

4
This is a test case
 

输出样例:

asa T
st ih
e tsi
 ce s



import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int N = Integer.valueOf(scanner.nextLine());
        char[] chars=scanner.nextLine().toCharArray();
        int k=0;
        if(chars.length%N==0){
            k=chars.length/N;
        }else {
            k=chars.length/N+1;
        }
        for (int i=0;i<N;i++){
            for (int j=i+(k-1)*N;j>=0;j-=N){
                if (j<chars.length){
                    System.out.print(chars[j]);
                }else {
                    System.out.print(" ");
                }

            }
            System.out.println();
        }

    }
}

标签:20,scanner,int,chars,System,039,L1,排版,Scanner
来源: https://www.cnblogs.com/zjwei/p/14645711.html