其他分享
首页 > 其他分享> > # 1086 Tree Traversals Again (25 分)

# 1086 Tree Traversals Again (25 分)

作者:互联网

1086 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
在这里插入图片描述

Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

代码如下

#include<bits/stdc++.h>
using namespace std;

typedef struct tnode* tree;
struct tnode
{
	int data;
	tree left, right;
};

tree build(int* pre, int* mid, int n)
{
    if(n <= 0)
        return NULL;
	int* p = mid;
	while (true)
	{
		if (*p == *pre)
			break;
		p++;
	}
	int zuo = p - mid, you = n - zuo - 1;
	tree L = (tree)malloc(sizeof(struct tnode));
	L->data = *p;
	L->left = build(pre + 1, mid, zuo);
	L->right = build(pre + zuo + 1, p + 1, you);
	
	return L;
}

int flag = 0;

void print(tree root)
{
	if (root)
	{
		print(root->left);
		print(root->right);
		if (!flag)
		{
			printf("%d", root->data);
			flag = 1;
		}
		else
		{
			printf(" %d", root->data);
		}
	}
}
int main()
{
    int pre[35], mid[35], k1 = 0, k2 = 0;
	int n;
	cin >> n;
	stack<int> st;
	for (int i = 0; i < 2 * n; i++)
	{
		string order;
		cin >> order;
		if (order == "Push")
		{
			int num;
			cin >> num;
			pre[k1++] = num;
			st.push(num);
		}
		else
		{
			mid[k2++] = st.top();
			st.pop();
		}
	}

	tree root = build(pre, mid, n);
	print(root);

	return 0;
}

标签:pre,1086,int,tree,Traversals,Tree,pop,Push,root
来源: https://blog.csdn.net/ysm1575491969/article/details/115311819