未名湖畔的烦恼
作者:互联网
租自行车
春天到了,某公园租自行车的生意火爆,上午自行车就会全部租完,到了中午的时候,租车窗口排起了长龙,
假设还车的有r个人,租车的有b个人。现在的问题是,这些人有多少种排法,可以避免出现无车可租的情况。
输入格式
两个整数,表示r和b
输出格式
一个整数,表示队伍的排法的方案数。
样例输入
2 3
样例输出
0
样例输入
3 2
样例输出
5
数据规模和约定
r,b∈[0,16]
测试集1
系统输入:16 16
预期输出:35357670
测试集2
系统输入:16 14
预期输出:25662825
测试集3
系统输入:15 16
预期输出:0
package the_blue_cup;
import java.util.Scanner;
//未名湖畔的烦恼
public class Demo_24 {
// 换车的人用r表示,租车的人用b表示
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int r = sc.nextInt();
int b = sc.nextInt();
System.out.println(fun(r, b));
sc.close();
}
private static int fun(int r, int b) {
if(r < b) return 0;//当租车的人大于换车的人
if(b == 0) return 1;//当租车的人为0
return fun(r-1,b) + fun(r, b-1);
}
}
结果:输入16 16
输出 35357670
标签:输出,16,int,样例,烦恼,租车,未名湖畔,输入 来源: https://blog.csdn.net/m0_49153993/article/details/114705674