其他分享
首页 > 其他分享> > PAT 1025 PAT Ranking

PAT 1025 PAT Ranking

作者:互联网

    Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

    For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

    The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

Code:

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

struct student{
    char id[15];
    int score = 0;
    int location_number = 0; 
    int local_rank = 0;
}stu[30010];


bool cmp(student a,student b){
    if(a.score == b.score){
        return strcmp(a.id,b.id) < 0;
    }else{
        return a.score > b.score;
    }
}
   

int main(){
    int n,k,num = 0;
    scanf("%d", &n);         
    
    for( int i = 1 ; i <= n ; i++ ){ 
        scanf("%d",&k);					
        for(int j = 0 ; j < k ; j++){ 
            scanf("%s %d",stu[num].id,&stu[num].score);
            stu[num].location_number = i;
            num ++;
        }
        sort(stu+num-k,stu+num,cmp);
        stu[num-k].local_rank = 1;
        for(int j = num-k+1;j<num;j++){
        	if(stu[j].score == stu[j-1].score){
        		stu[j].local_rank= stu[j-1].local_rank;
			}else{
				stu[j].local_rank = j + 1 - (num-k);
			}
		} 
    }

    printf("%d\n",num);
    sort(stu,stu + num,cmp);
    int r = 1;
    for( int i = 0 ; i < num ; i++ ){ 
        if( i > 0 && stu[i].score != stu[i-1].score){
        	r = i + 1;
		}
        printf("%s ",stu[i].id);
        printf("%d %d %d\n",r,stu[i].location_number,stu[i].local_rank);
    }
    return 0;
}

Thinking:

      代码是《算法笔记》上的答案,感觉真的很巧妙,一次循环就可以解决很多的问题,我是真滴菜,代码一直存在运行超时的问题,还是要多吸收优秀代码,多练习才能提高姿势水平。

第一道算法题纪念    2021/3/10

 顺便贴上我上大一时人生第一次编写的超级简单的c++代码(无论从哪个角度看都不忍直视,哈哈,曾经我也是个“左括号要换行党”),高山仰止,景行行止,一直在进步,一直有收获,一直要努力。

标签:1025,Ranking,PAT,int,number,rank,stu,score,test
来源: https://blog.csdn.net/weixin_43717253/article/details/114628909