其他分享
首页 > 其他分享> > 1117 Eddington Number (25 分)

1117 Eddington Number (25 分)

作者:互联网

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.

Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8
 

Sample Output:

6
 
#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
bool cmp(int a,int b){
    return a>b;
}
int main(){
    vector<int> v;
    int n;
    cin>>n;
    v.resize(n);
    for(int i=0;i<n;i++){
        cin>>v[i];
    }
    sort(v.begin(),v.end(),cmp);
    int E=0;
    while(E<n&&v[E]>E+1){
        E++;
    }
    cout<<E<<endl;
    return 0;
}

 

 

标签:case,25,distances,int,days,Number,1117,line,Eddington
来源: https://www.cnblogs.com/dreamzj/p/14460776.html