其他分享
首页 > 其他分享> > 1107 Social Clusters (30 point(s))

1107 Social Clusters (30 point(s))

作者:互联网

1107 Social Clusters (30 point(s))

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K
​i
​​ : h
​i
​​ [1] h
​i
​​ [2] … h
​i
​​ [K
​i
​​ ]

where K
​i
​​ (>0) is the number of hobbies, and h
​i
​​ [j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1

#include<bits/stdc++.h>
using namespace std;
int father[1010];
int isRoot[1010];//记录每个社群有几个人
int cluster[1010]={0};//记录活动编号
int n,m,k;
bool cmp(int a,int b){
    return a>b;
}
int findFather(int x){
    int a=x;
    while(x!=father[x]){
        x=father[x];
    }
    while(a!=father[a]){//路径压缩
        int z=a;
        a=father[a];
        father[z]=x;
    }
    return x;
}
void Union(int a,int b){
    int faA=findFather(a);
    int faB=findFather(b);
    if(faA!=faB)
        father[faA]=faB;
}
void init(int n){
    for(int i=1;i<=n;++i){
        father[i]=i;
        isRoot[i]=0;
    }
}
int main(){
    scanf("%d",&n);
    init(n);
    for(int i=1;i<=n;++i){
        scanf("%d:",&m);
        for(int j=0;j<m;++j){
            scanf("%d ",&k);
            if(cluster[k]==0) cluster[k]=i;//若没有这项活动
            Union(i,findFather(cluster[k]));
        }
    }
    for(int i=1;i<=n;++i){
        isRoot[findFather(i)]++;
    }
    int ans=0;
    for(int i=1;i<=n;++i)
        if(isRoot[i]) ans++;
    sort(isRoot+1,isRoot+n+1,cmp);
    printf("%d\n",ans);
    for(int i=1;i<=ans;++i){
        if(i!=1) printf(" ");
        printf("%d",isRoot[i]);
    }
}

标签:1107,int,30,father,cluster,findFather,Clusters,line,people
来源: https://blog.csdn.net/weixin_44970602/article/details/114239673