其他分享
首页 > 其他分享> > 1130 Infix Expression (25 分)

1130 Infix Expression (25 分)

作者:互联网

1130 Infix Expression (25 分)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child
where data is a string of no more than 10 characters, left_child and right_child are the indices of this node’s left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.
Figure 1Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8

Sample Output 1:

(a+b)(c(-d))

Sample Input 2:

8
2.35 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

只有三种情况,左右子树不空, 左子树空右子树不空,左右子树都空,然后dfs就好。返回时注意最外围有括号的话不能输出括号

#include<bits/stdc++.h>
using namespace std;
struct Node {
	string data;
	int l, r;
}a[100];

string dfs(int root) {
	if (a[root].l == -1 && a[root].r == -1) return a[root].data;
	else if (a[root].l == -1 && a[root].r != -1) return "(" + a[root].data + dfs(a[root].r) + ")";
	else if (a[root].l != -1 && a[root].r != -1) return "(" + dfs(a[root].l) + a[root].data + dfs(a[root].r) + ")";
}
int main() {
	int have[100] = {0}, n, root = 1;
	string d;
	scanf("%d", &n);
	for (int i = 1; i <= n; i++) {
		cin >> a[i].data;
		scanf("%d %d", &a[i].l, &a[i].r);
		if (a[i].l != -1) have[a[i].l] = 1;
		if (a[i].r != -1) have[a[i].r] = 1;
	}
	while(have[root] == 1) root++;
	string ans = dfs(root);
	if (ans[0] == '(') cout << ans.substr(1, ans.size() - 2);
	else cout << ans;
}

标签:25,string,int,root,1130,dfs,data,child,Expression
来源: https://blog.csdn.net/shshbdhsjjd/article/details/114063592