其他分享
首页 > 其他分享> > 1142 Maximal Clique (25 分) 图论

1142 Maximal Clique (25 分) 图论

作者:互联网

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
 

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
#define  inf  0x3fffffff
int e[maxn][maxn],n,m,k;
void check(int dex){
    int kk;
    scanf("%d",&kk);
    vector<int> v(kk);
    for(int i=0;i<kk;i++){
        scanf("%d",&v[i]);
    }
    for(int i=0;i<kk-1;i++){
        if(e[v[i]][v[i+1]]==inf){
            printf("Not a Clique\n");
            return ;
        }
    }
    int flag,flag2=0,cnt;
    for(int i=1;i<=n;i++){
        flag=1;
        cnt=0;
        for(int j=0;j<kk;j++){
            if(i==v[j]){
                flag=0;
                break;
            }
        }
        if(flag==1){
            for(int j=0;j<kk;j++){
                if(e[i][v[j]]==1){
                    cnt++;
                }
            }
            if(cnt==kk){
                printf("Not Maximal\n");
                flag2=1;
                break;
            }
        }
    }
    if(flag2==0){
        printf("Yes\n");
    }
}
int main(){
    fill(e[0],e[0]+maxn*maxn,inf);
    scanf("%d %d",&n,&m);
    for(int i=0;i<m;i++){
        int a,b;
        scanf("%d %d",&a,&b);
        e[a][b]=e[b][a]=1;
    }
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        check(i);
    }
    return 0;
}

 

标签:1142,Maximal,25,int,graph,Clique,vertices,clique,Yes
来源: https://www.cnblogs.com/dreamzj/p/14427571.html