其他分享
首页 > 其他分享> > PAT 1027 Colors in Mars

PAT 1027 Colors in Mars

作者:互联网

目录

问题描述

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for , the middle 2 digits for , and the last 2 digits for . The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.RedGreenBlue

Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:
For each test case you should output the Mars RGB value in the following format: first output , then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a to its left.#0

Sample Input:
15 43 71
Sample Output:
#123456

思路分析及代码实现

li = {0: '0', 1: '1', 2: '2', 3: '3', 4: '4', 5: '5', 6: '6', 7: '7', 8: '8', 9: '9', 10: 'A', 11: 'B', 12: 'C'}
res = '#'
for i in range(3):
    n = int(input())
    res += li[n // 13] + li[n % 13]
print(res)

标签:digits,digit,PAT,color,res,1027,Colors,Mars,output
来源: https://blog.csdn.net/qaqlalala/article/details/113844392