其他分享
首页 > 其他分享> > 【ACM-OJ】《Til the Cows Come Home》C语言

【ACM-OJ】《Til the Cows Come Home》C语言

作者:互联网

【ACM-OJ】《Til the Cows Come Home》C语言

题目描述

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

输入

输出

样例输入

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

样例输出

90

提示

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

AC代码

//
//  main.c
//  Til the Cows Come Home
//
//  Created by HISS on 2020/11/12.
//  Copyright © 2020 HISS. All rights reserved.
//

#include <stdio.h>
#define Max 0x3fffffff

int map[1005][1005];
int dis[1005];

void dijkstra(int n)
{
    int visit[1001] = {0};
    int min, i, j, k;
    visit[1] = 1;
    for(i = 1; i < n; ++ i)
    {
        min = Max;
        k = 1;
        for(j = 1; j <= n; ++ j)
        {
            if(!visit[j] && min > dis[j])
            {
                min = dis[j];
                k = j;
            }
        }
        visit[k] = 1;
        for(j = 1; j <= n; ++ j)
        {
            if(!visit[j] && dis[j] > dis[k] + map[k][j])
                dis[j] = dis[k] + map[k][j];
        }
    }
    printf("%d\n", dis[n]);
}

int main()
{
    int t, n, i, j, from, to, cost;
    while(scanf("%d %d", &t, &n)!=EOF)
    {
        for(i = 1; i <= n; ++ i)
        {
            map[i][i] = 0;
            for(j = 1; j < i; ++ j)
                map[i][j] = map[j][i] = Max;
        }
        for(i = 1; i <= t; ++ i)
        {
            scanf("%d %d %d", &from, &to, &cost);
            //可能有多条路,只记录最短的
            if(cost < map[from][to])
                map[from][to] = map[to][from] = cost;
        }
        for(i = 1; i <= n; ++ i)
            dis[i] = map[1][i];
        dijkstra(n);
    }
}

标签:map,OJ,get,int,visit,ACM,C语言,Bessie,dis
来源: https://blog.csdn.net/weixin_47356269/article/details/113818576