其他分享
首页 > 其他分享> > 2020 BIT冬训-二分三分快速幂矩阵 B - Error Curves HDU - 3714

2020 BIT冬训-二分三分快速幂矩阵 B - Error Curves HDU - 3714

作者:互联网

Problem Description Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm's efficiency, she collects many datasets.
What's more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.
It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?  

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.OutputFor each test case, output the answer in a line. Round to 4 digits after the decimal point.

 

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000
本题的题意是给若干个下凸形抛物线函数,对每个属于[0, 1000]之间的x取函数的最大值。求这个最大值的最小值为多少。
由于都是下凸形函数,且取完最大值后的函数图像仍是下凸形函数。我们需要用到三分法。
三分寻找[0, 1000]区间内的x再输出对应的函数值即可。
注意精度为1e-9。
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
int t,n,a[10005],b[10005],c[10005];
double l,r,mid,midr;
double ans(double x){
    double temp=a[0]*x*x+b[0]*x+c[0];
    for(int i=1;i<n;i++)
        temp=max(temp,a[i]*x*x+b[i]*x+c[i]);
    return temp;
}
int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d%d%d",&a[i],&b[i],&c[i]);
        }
        l=0,r=1000;
        while(r-l>1e-9){
            mid=(l+r)/2;
            midr=(mid+r)/2;
            if(ans(mid)<ans(midr))
                r=midr;
            else
                l=mid;        
        }
    printf("%.4lf\n",ans(l));
    
    }
}

 

 

标签:function,3714,HDU,many,each,Curves,she,error,test
来源: https://www.cnblogs.com/mikku39/p/14400949.html